MultiMAN ver 04.19.07 now available

Written by Tech84 on February 14, 2013

MultiMAN ver 04.19.07 is now available available for download. Busy man Deank is back again with another update to his ever popular file manager with the Multiman 04.19.07 update. It’s just another minor update adding support for PSOne multi-disc games.

Multiman Logo

Here is a list included in this very small update:

* Added support for multi-disc games when using PS1_NETEMU emulator
With this update the ps1 backups support saga should be concluded.

You can download MultiMAN 04.19.07 here. (21.77MB which includes CEX/DEX/STEALTH updates)

One more thing, Deank has also announced that for futures updates like Multiman 05.00.00, older firmwares will no longer be supported. However, future firmwares will still be supported including the 4.30 ones.

With multiMAN 05.00.00 only 4.30 and higher firmwares will be supported. Supporting 14 different firmwares is too hard to maintain compatibility with.

These will no longer be supported:
3.41 OFW
3.41 OFW + DONGLE
3.41 MFW (HERMES)
3.55 OFW
3.55 CFW KMEAW
3.55 CFW COBRA
3.55 CFW TB
3.55 CFW REBUG/ROGERO
3.55 OFW DEX
3.55 CFW DEX
4.21 OFW DEX
4.21 CFW REBUG
4.21 CFW ROGERO 1.00..2.03

These and later will be supported:
4.30 CFW ROGERO 2.05..
4.30 CFW REBUG
4.31 CFW

It makes sense though, working on the compatibility for 14 other firmwares takes a lot of effort and time. And it’s only logical that people should be updating their firmwares OFW or CFW to the newest and most stable version to date. I do hope that other developers would pick up on this by following Deanks footsteps and create their own file managers that would support older firmwares. You know, even just for the lols.

[Source]

Anyway, make sure to come back here to get the latest Multiman updates!




 Posted in Multiman, PS3, PS3 Homebrew, Tech,

3 Responses to “MultiMAN ver 04.19.07 now available”

  1. neoceaser says:

    stop talkling crap this sucks instead of supporting true CFW u r supporting 4xx crappy firmwares. U lost my respect Deank

  2. Noi1tra says:

    So Multiman does not work for all firmwares?

Leave a Reply

Looking for something?

Use the form below to search the site:

Still not finding what you're looking for? Drop a comment on a post or contact us so we can take care of it!